Back to overview
Resolved

Investigating — Service Unavailable

Jul 24, 2026 at 11:03am UTC
Affected services
tcghaultracker.com

Resolved
Jul 24, 2026 at 11:12am UTC

July 24, 2026 — 11:10 UTC

TCGHaulTracker is back online. We experienced approximately 12 minutes of downtime beginning at 10:58 UTC. All services are now operating normally. We are investigating the root cause.

Created
Jul 24, 2026 at 11:03am UTC

July 24, 2026 — 11:03 UTC

We are investigating reports of users being unable to access TCGHaulTracker. Our team is looking into the issue and will provide an update shortly.